2.3. Using Plug-in Archive

2.3.1. Downloading

The latest version of JasperAssistant is always available from http://www.jasperassistant.com.

Support for Eclipse 2.1.x/WSAD 5.1.x

Since version 2.1.0, JasperAssistant requires Eclipse 3.0.x or higher. Eclipse 2.1.x and WSAD 5.1.x are only supported by versions 2.0.5 or earlier of JasperAssistant. Eclipse 3.2.x is supported since version 2.1.2. Eclipse 3.3.x is supported since version 2.3.0

2.3.2. Prerequisites

Different versions of JasperAssistant have different prerequisites. Depending on the target version of Eclipse IDE, follow the list of prerequisites for that specific version.

Eclipse 3.5.x

  1. Version 1.5 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.5.x must be installed. Eclipse SDK 3.5.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.5.x. GEF Runtime is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 3.4.x

  1. Version 1.5 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.4.x must be installed. Eclipse SDK 3.4.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.4.x. GEF Runtime is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 3.3.x

  1. Version 1.5 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.3.x must be installed. Eclipse SDK 3.3.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.3.x. GEF Runtime is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 3.2.x

  1. Version 1.4.1 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.2.x must be installed. Eclipse SDK 3.2.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.2.x. GEF Runtime 3.2.x is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 3.1.x

  1. Version 1.4.1 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.1.x must be installed. Eclipse SDK 3.1.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.1.x. GEF Runtime 3.1.x is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 3.0.x

  1. Version 1.4.1 or higher of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 3.0.x must be installed. Eclipse SDK 3.0.x can be downloaded from the following address:

    http://www.eclipse.org

  3. Graphical Editing Framework (GEF) 3.0.x. GEF Runtime 3.0.x is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

The following prerequisites must be satisfied to install JasperAssistant 2.0.5 or earlier under Eclipse 2.1.x / WSAD 5.1.x

Eclipse 2.1.3 / WSAD 5.1.2

  1. Version 1.3 or 1.4 of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 2.1.3 or WSAD 5.1.2 must be installed.

  3. Graphical Editing Framework (GEF) 2.1.3 Plug-in must be installed. GEF Runtime 2.1.3 is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

Eclipse 2.1.2 / WSAD 5.1.1

  1. Version 1.3 or 1.4 of Java Runtime Environment (JRE) or Java Development Kit (JDK) must be installed.

  2. Eclipse SDK 2.1.2 or WSAD 5.1.1 must be installed. Eclipse SDK 2.1.2 can be downloaded from the following address:

  3. Graphical Editing Framework (GEF) 2.1.2 Plug-in must be installed. GEF Runtime 2.1.2 is distributed by Eclipse.org and can be downloaded from the following address:

    http://www.eclipse.org/gef/downloads/

2.3.3. Installing

To install JasperAssistant you must perform the following steps:

  1. Stop the Eclipse IDE

  2. Unzip GEF distribution archive into your Eclipse installation folder.

  3. Unzip JasperAssistant distribution archive into your Eclipse installation folder.

  4. Start the Eclipse IDE

To verify that the installation was done properly check that the following directories or files exist:

<ECLIPSE_HOME>/features/com.jasperassistant.designer_3.1.1
<ECLIPSE_HOME>/plugins/com.jasperassistant.designer_3.1.1

Also check the existence of the following directories or files to ensure the correct installation of the GEF plug-in:

For Eclipse 3.5.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.5.x.xxx
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.5.x.xxx.jar
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.5.x.xxx.jar

For Eclipse 3.4.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.4.x.xxx
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.4.x.xxx.jar
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.4.x.xxx.jar

For Eclipse 3.3.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.3.x.xxx
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.3.x.xxx.jar
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.3.x.xxx.jar

For Eclipse 3.2.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.2.x.xxx
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.2.x.xxx.jar
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.2.x.xxx.jar

For Eclipse 3.1.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.1.x
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.1.x.jar
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.1.x.jar

For Eclipse 3.0.x:

<ECLIPSE_HOME>/features/org.eclipse.gef_3.0.x
<ECLIPSE_HOME>/plugins/org.eclipse.gef_3.0.x
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_3.0.x

For Eclipse 2.1.x / WSAD 5.1.1/5.1.2:

<ECLIPSE_HOME>/features/org.eclipse.gef_2.1.x
<ECLIPSE_HOME>/plugins/org.eclipse.gef_2.1.x
<ECLIPSE_HOME>/plugins/org.eclipse.draw2d_2.1.x