JasperAssistant Update Site

The JasperAssistant Update Site contains feature and plug-in distribution files for JasperAssistant Report Designer. You can download and install this distributions using the Eclipse Update as described below. See manual installation instructions if you wish to download and install the plugin yourself.

JRE prerequisites

JasperAssistant requires that you use at least version 5 of Java runtime environment (JRE). Older versions of JasperAssistant (< 3.1.0) can be used with JRE 1.4.2.

Installing the plug-in using Eclipse Update

  • From the Eclipse menu, select Help->Software Updates->Find and Install. This will open the Install/Update wizard.
  • On the fist page, select the "Search for new features to install" option and click Next.
  • On the second page, click the "New Remote Site..." button and enter the following information:

    • Name: JasperAssistant update site
    • URL: http://www.jasperassistant.com/updates/3.x/

    For Eclipse 3.1.x, additionally add the following remote update site which is required to install the GEF plug-in:

    • Name: Eclipse 3.0 update site
    • URL: http://update.eclipse.org/updates/3.0/

    Select the desired version of JasperAssistant and GEF SDK as shown below:

    Select Sites
  • On the next page, select the JasperAssistant and Graphical Editing Framework features and click Next.
  • Read carefully JasperAssistant license agreement and choose "I accept the terms of license agreement" to accept it.
  • On the next page select the install location (the default location is recommended) and click Finish to start the plug-in installation. Accept the IDE restart at the end.

Memory settings

The Preview Feature of JasperAssistant can consume a significant amount of memory depending on the size of your reports. It is recommended that you increase the default memory settings used when running Eclipse. The following line starts Eclipse with 512M for its memory allocation pool:

eclipse -vmargs -Xmx512m

When using a Sun VM, you may also need to increase the size of the permanent generation memory. The default maximum is 64 megabytes, but more may be needed depending on your plug-in configuration and use. The maximum permanent generation size is increased using the following command line:

eclipse -vmargs -XX:MaxPermSize=128

Starting with Eclipse 3.2, memory settings can be made in eclipse.ini file that is located in Eclipse installation directory. Put the following options at the end of eclipse.ini file, one option per line:


-vmargs
-XX:MaxPermSize=128m
-Xms40m
-Xmx512m

Using the plug-in

We strongly recommend that before you start using JasperAssistant, you also take a look at the F.A.Q section that answers several common questions.